Database outage

Incident Report for NTP Pool System Status

Resolved

Database cluster has been re-installed and stable for about an hour now.
Posted Sep 25, 2025 - 10:26 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Sep 25, 2025 - 00:20 UTC

Investigating

The database is having an outage (again!). Investigating.
Posted Sep 24, 2025 - 22:44 UTC
This incident affected: Management Portal, Public website, DNS updates, and Monitoring System.