Management site down

Incident Report for NTP Pool

Resolved

Except for some internal metrics gathering (for example the DNS query counters) the system should be fully working again.
Posted Apr 12, 2023 - 08:45 UTC

Investigating

Routine maintenance on the management system and website backend went awry so they are currently unavailable or sporadicly available.
Posted Apr 12, 2023 - 04:43 UTC
This incident affected: Management Portal and Public website.