status.ntppool.org is missing TLS
Incident Report for NTP Pool
Resolved
The helpful folks at statuspage.io added a certificate for status.ntppool.org today so that domain will now work in browsers with working HSTS.
Posted almost 2 years ago. Aug 30, 2016 - 04:20 UTC
Identified
The ntppool.org domain requires TLS for all sub-domains, but the status.ntppool.org site doesn't have a certificate yet so it won't load in some browsers. The alternate domain ntppool.statuspage.io works (as you might have found out if you're reading this).
Posted almost 2 years ago. Aug 27, 2016 - 20:00 UTC